Summary
On July 31, 2024, during our latest Production release, our SSO system experienced an outage that lasted approximately 2 hours. During this time, users were unable to log in to our platform using SSO and saw an error screen instead. We quickly received reports from customers about this issue, which prompted our Engineering team to start an immediate investigation.
Cause
We identified the root cause of the outage as an update to one of our application libraries, which contained a critical bug and was mistakenly included in our code base.
Resolution
Approximately one hour after the first report of the issue, the affected library was updated to version 6.4.10, which resolved the problem. A thorough review of this incident has been conducted and preventative measures have been put in place to further increase stability during production releases.